Page 1 of 1

Solo instead of G:MP

Posted: Thu Nov 02, 2017 6:20 pm
by Fargo785
Hello guys,

When I launch G:MP, instead of loading the multiplayer screen, I get the "normal" screen game.

https://i.imgur.com/VHHNzEz.jpg

Plus, I have this error on my screen
Failed to create directX device and swapchain!

Client log

Code: Select all

[19:14:51] [Debug] [CMain] Skipping game logos.
[19:14:51] [Debug] [CMain] Disabling Legals.
[19:14:51] [CMain] GTA 5 Setup.
[19:14:51] [Debug] [CConfig] Loaded config.
[19:14:51] [Debug] DXINIT
[19:14:51] [Debug] [CEF] Game resolution 1920 x 1080 - Windowed: 1.
[19:14:51] [Debug] [CEF] Desktop resolution 1920 x 1080.
GameHook log

Code: Select all

[19:14:41] Registering script 'Client' (0x00007FF9C56E05C0)
[19:14:41] Initializing...
[19:14:41] [Debug] Loaded Modules: 
[19:14:41] [Debug] 	D:\Steam\steamapps\common\Grand Theft Auto V\GTA5.exe (0x7EFC0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\ntdll.dll (0xFB070000)
[19:14:41] [Debug] 	C:\Windows\System32\KERNEL32.DLL (0xFA770000)
[19:14:41] [Debug] 	C:\Windows\System32\KERNELBASE.dll (0xF82C0000)
[19:14:41] [Debug] 	C:\Windows\System32\USER32.dll (0xFA820000)
[19:14:41] [Debug] 	C:\Windows\System32\win32u.dll (0xF7590000)
[19:14:41] [Debug] 	C:\Windows\System32\GDI32.dll (0xFAF80000)
[19:14:41] [Debug] 	C:\Windows\System32\gdi32full.dll (0xF7EC0000)
[19:14:41] [Debug] 	C:\Windows\System32\msvcp_win.dll (0xF8220000)
[19:14:41] [Debug] 	C:\Windows\System32\ucrtbase.dll (0xF7660000)
[19:14:41] [Debug] 	C:\Windows\System32\WS2_32.dll (0xFA3E0000)
[19:14:41] [Debug] 	C:\Windows\System32\sechost.dll (0xFA450000)
[19:14:41] [Debug] 	C:\Windows\System32\RPCRT4.dll (0xFA640000)
[19:14:41] [Debug] 	C:\Windows\System32\PSAPI.DLL (0xFB060000)
[19:14:41] [Debug] 	C:\Windows\System32\CRYPT32.dll (0xF8050000)
[19:14:41] [Debug] 	C:\Windows\System32\MSASN1.dll (0xF7520000)
[19:14:41] [Debug] 	C:\Windows\System32\WINTRUST.dll (0xF7E60000)
[19:14:41] [Debug] 	C:\Windows\System32\msvcrt.dll (0xF85D0000)
[19:14:41] [Debug] 	C:\Windows\System32\advapi32.dll (0xF8670000)
[19:14:41] [Debug] 	C:\Windows\System32\IMM32.dll (0xFA4B0000)
[19:14:41] [Debug] 	C:\Windows\System32\SHLWAPI.dll (0xF9ED0000)
[19:14:41] [Debug] 	C:\Windows\System32\combase.dll (0xF9F30000)
[19:14:41] [Debug] 	C:\Windows\System32\bcryptPrimitives.dll (0xF8560000)
[19:14:41] [Debug] 	C:\Windows\System32\SHELL32.dll (0xF8720000)
[19:14:41] [Debug] 	C:\Windows\System32\cfgmgr32.dll (0xF8510000)
[19:14:41] [Debug] 	C:\Windows\System32\shcore.dll (0xFA330000)
[19:14:41] [Debug] 	C:\Windows\System32\windows.storage.dll (0xF7760000)
[19:14:41] [Debug] 	C:\Windows\System32\kernel.appcore.dll (0xF7500000)
[19:14:41] [Debug] 	C:\Windows\System32\powrprof.dll (0xF7540000)
[19:14:41] [Debug] 	C:\Windows\System32\profapi.dll (0xF74E0000)
[19:14:41] [Debug] 	C:\Windows\System32\ole32.dll (0xFA4F0000)
[19:14:41] [Debug] 	C:\Windows\System32\OLEAUT32.dll (0xFAEC0000)
[19:14:41] [Debug] 	D:\Steam\steamapps\common\Grand Theft Auto V\steam_api64.dll (0x64840000)
[19:14:41] [Debug] 	D:\Steam\steamapps\common\Grand Theft Auto V\GFSDK_ShadowLib.win64.dll (0xC0E50000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\VERSION.dll (0xF3670000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\DSOUND.dll (0xD66A0000)
[19:14:41] [Debug] 	D:\Steam\steamapps\common\Grand Theft Auto V\bink2w64.dll (0xE08A0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\WINMM.dll (0xEFF60000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\MF.dll (0xCE250000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\MFPlat.DLL (0xE5350000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\msdmo.dll (0xF4880000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\MFReadWrite.dll (0xCFCF0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\PROPSYS.dll (0xF3130000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\WTSAPI32.dll (0xF3CD0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\d3d9.dll (0xC5C70000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\D3DCOMPILER_43.dll (0xC5A00000)
[19:14:41] [Debug] 	D:\Steam\steamapps\common\Grand Theft Auto V\GFSDK_TXAA_AlphaResolve.win64.dll (0xE2EB0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\XINPUT1_3.dll (0x00400000)
[19:14:41] [Debug] 	C:\Windows\System32\SETUPAPI.dll (0xFAA80000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\IPHLPAPI.DLL (0xF6B90000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\DINPUT8.dll (0xE0850000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\d3dx9_43.dll (0xC4E50000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\WINMMBASE.dll (0xEFF30000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\dwmapi.dll (0xEA060000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\OPENGL32.dll (0xD83F0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\GLU32.dll (0xEE630000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\MFCORE.DLL (0xC5F30000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\ksuser.dll (0xED790000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\bcrypt.dll (0xF70A0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\CRYPTBASE.DLL (0xF6F90000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\RTWorkQ.DLL (0xE7FA0000)
[19:14:41] [Debug] 	C:\Program Files (x86)\Steam\gameoverlayrenderer64.dll (0xE0930000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\Client.dll (0xC56D0000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\GameHook.dll (0xC55E0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\D3DCOMPILER_47.dll (0xF4900000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\FW1FontWrapper.dll (0xE0830000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\d3d11.dll (0xF4D40000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\libcef.dll (0xAE630000)
[19:14:41] [Debug] 	C:\Windows\System32\COMDLG32.dll (0xFA970000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\MinHook.dll (0xE7BD0000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\RakNet.dll (0xC3DD0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\MSVCP140.dll (0xCA0D0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\VCRUNTIME140.dll (0xC0B80000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\CRYPTSP.dll (0xF6FA0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\dxgi.dll (0xF6430000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\USERENV.dll (0xF73E0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\OLEACC.dll (0xEFC20000)
[19:14:41] [Debug] 	C:\Windows\WinSxS\amd64_microsoft.windows.common-controls_6595b64144ccf1df_5.82.15063.413_none_0e0f5dcc67adff4e\COMCTL32.dll (0xEA600000)
[19:14:41] [Debug] 	D:\Programmes\Grand Multiplayer\chrome_elf.dll (0xC8770000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\dbghelp.dll (0xECDE0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\USP10.dll (0xED7C0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\credui.dll (0xE7B80000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\CRYPTUI.dll (0xEA090000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\NETAPI32.dll (0xF0CE0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\DWrite.dll (0xE5730000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\ncrypt.dll (0xF7070000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\Secur32.dll (0xED600000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\urlmon.dll (0xEF400000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\WINHTTP.dll (0xF0B30000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\dxva2.dll (0xE9090000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\WINSPOOL.DRV (0xE4BF0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\FONTSUB.dll (0xE0800000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\dhcpcsvc.DLL (0xF3AB0000)
[19:14:41] [Debug] 	C:\Windows\System32\NSI.dll (0xFA4E0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\NTASN1.dll (0xF7030000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\iertutil.dll (0xEE710000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\SAMCLI.DLL (0xF2DD0000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\NETUTILS.DLL (0xF6C80000)
[19:14:41] [Debug] 	C:\Windows\SYSTEM32\SSPICLI.DLL (0xF7410000)
[19:14:48] Input hook attached: WndProc 0x00000000FFFF00E9
[19:14:48] Initializing ScriptEngine...
[19:14:49] [Debug] scrThreadCollection	 0x00007FF681BAC240 (0x02BEC240)
[19:14:50] [Debug] activeThreadTlsOffset 0x00000830
[19:14:52] [Debug] scrThreadId		 0x00007FF681BABBA0 (0x02BEBBA0)
[19:14:55] [Debug] scrThreadCount	 0x00007FF681BAC580 (0x02BEC580)
[19:14:56] [Debug] registrationTable	 0x00007FF681BAB380 (0x02BEB380)
[19:14:56] [Debug] g_scriptHandlerMgr	 0x00007FF68142B230 (0x0246B230)
[19:14:57] [Debug] gameState		 0x00007FF680F5A16C (0x01F9A16C)
[19:14:58] [Debug] g_globalPtr		 0x00007FF681BAC380 (0x02BEC380)
[19:14:59] [Debug] g_entityPoolAddress	 0x00007FF681BACB30 (0x02BECB30)
[19:14:59] [Debug] g_vehiclePoolAddress	 0x00007FF68168CA70 (0x026CCA70)
[19:14:59] [Debug] g_pedPoolAddress	 0x00007FF68132AC00 (0x0236AC00)
[19:14:59] [Debug] g_objectPoolAddress	 0x00007FF681351458 (0x02391458)
[19:15:00] [Debug] g_pickupPoolAddress	 0x00007FF68133A488 (0x0237A488)
[19:15:01] g_addEntityToPoolFunc	 0x00007FF6804C8694 (0x01508694)
[19:15:01] Game Version Hex 0xc4834801
[19:15:01] Game version #34
[19:15:01] Checking if game is ready...
[19:15:01] Game ready
[19:15:01] [Debug] GtaThread collection size 189
[19:15:01] Registering script 'Client' (0x00007FF9C56E05C0)
[19:15:02] [Debug] Created thread, id 1
[19:15:02] Initialization finished
[19:20:24] Unregistered script 'Client'
[19:20:24] Cleanup
[19:20:24] [Debug] Removed input hook
Additionnal information: Steam, Windows 10

Re: Solo instead of G:MP

Posted: Thu Nov 02, 2017 6:32 pm
by Fargo785
Ok, I changed my resolution to 1600x900 (windowed). It works now! ;)

Re: Solo instead of G:MP

Posted: Sun Nov 05, 2017 1:46 pm
by No-Half-Measures
Thanks for the feedback, the Dxhook shouldn't fail because of 'max resolution' but scaling down would fix the CEF draw issue caused by that.
Was this your first attempt launching GrandM which failed? or was is consistently happening when at 1920x1080?

Re: Solo instead of G:MP

Posted: Mon Nov 06, 2017 8:29 pm
by Fargo785
No-Half-Measures wrote:
Sun Nov 05, 2017 1:46 pm
Thanks for the feedback, the Dxhook shouldn't fail because of 'max resolution' but scaling down would fix the CEF draw issue caused by that.
Was this your first attempt launching GrandM which failed? or was is consistently happening when at 1920x1080?
You're welcome.

It was consistently happening at 1920x1080 so I changed the resolution and it worked.

Re: Solo instead of G:MP

Posted: Tue Nov 07, 2017 5:38 pm
by No-Half-Measures
Fargo785 wrote:
Mon Nov 06, 2017 8:29 pm
No-Half-Measures wrote:
Sun Nov 05, 2017 1:46 pm
Thanks for the feedback, the Dxhook shouldn't fail because of 'max resolution' but scaling down would fix the CEF draw issue caused by that.
Was this your first attempt launching GrandM which failed? or was is consistently happening when at 1920x1080?
You're welcome.

It was consistently happening at 1920x1080 so I changed the resolution and it worked.
Ok, well I've been successful in reproducing the failure in the dxhook and have a pretty good idea to the cause of it too, so this will be fixed in the upcoming patch (No ETA) along with a fix for the CEF Failure for max resolution as I have fixed it on my end and have the helpers testing it atm.