Vehicle related issues

Calabresi
Posts: 1
Joined: Fri Jun 23, 2017 11:57 am

Vehicle related issues

Mon Sep 25, 2017 6:40 pm

Hello there.

I've just been using C++ SDK and tried some stuff on a local Windows server. Noticed those bugs on server;

  • Vehicles always change their model back to Dilettante after being streamed out & streamed back in. I've been using Vehicle class implemented along with its Create() function.
  • Changing vehicle's position via API::Entity::SetPosition causes players are inside the vehicle to get thrown out.
  • Sometimes, entities who's been thrown out the way I described above, cannot enter driver seat again unless they try to enter passenger seat first.
  • If you try to change a vehicle's position via Vehicle class' SetPosition(), it makes the vehicle undrivable. You can get in, but the vehicle will not move.
  • Very rarely, a tractor with a ped spawns and drives in dirt roads near farms. I've seen this only once and didn't take a screenshot, but I'm very certain it happens.
  • Edit: I've also seen a garbage truck on highway. Pretty sure something's wrong with emptying the world.
  • Edit 2: I've got on screenshot this time. Many vehicles on highway: https://imgur.com/a/kW1MH
Please note that I've been using my own plugin compiled with C++ SDK, I haven't tested Freeroam plugin included with server.
0 x
User avatar
No-Half-Measures
Developer
x 15
Posts: 41
Joined: Mon May 15, 2017 12:01 pm

Re: Vehicle related issues

Mon Sep 25, 2017 8:44 pm

Can you reproduce;
Vehicles always change their model back to Dilettante after being streamed out & streamed back in. I've been using Vehicle class implemented along with its Create() function.
And then post your Client.log and GameHook.log here when you have done so.

As to peds and their vehicles randomly showing up it's listed on our trello

The rest will be looked into.
0 x

Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest